summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/kernel/qsharedmemory/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/kernel/qsharedmemory/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/kernel/qsharedmemory/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/tests/auto/corelib/kernel/qsharedmemory/CMakeLists.txt b/tests/auto/corelib/kernel/qsharedmemory/CMakeLists.txt
index f853f00440..5553dfd56b 100644
--- a/tests/auto/corelib/kernel/qsharedmemory/CMakeLists.txt
+++ b/tests/auto/corelib/kernel/qsharedmemory/CMakeLists.txt
@@ -1,6 +1,4 @@
-# Generated from qsharedmemory.pro.
-
-if(QT_FEATURE_sharedmemory) # special case
+if(QT_FEATURE_sharedmemory)
#####################################################################
## tst_qsharedmemory Test:
#####################################################################
@@ -16,9 +14,11 @@ if(QT_FEATURE_sharedmemory) # special case
#####################################################################
qt_internal_extend_target(tst_qsharedmemory CONDITION LINUX
- PUBLIC_LIBRARIES
- rt
+ PUBLIC_LIBRARIES
+ rt
)
-# if(QT_FEATURE_sharedmemory) # special case
add_subdirectory(producerconsumer)
+ if(QT_FEATURE_process)
+ add_dependencies(tst_qsharedmemory producerconsumer_helper)
+ endif()
endif()