summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/platform/android/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/platform/android/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/platform/android/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/auto/corelib/platform/android/CMakeLists.txt b/tests/auto/corelib/platform/android/CMakeLists.txt
index 5154e0964c..6b7e9b2901 100644
--- a/tests/auto/corelib/platform/android/CMakeLists.txt
+++ b/tests/auto/corelib/platform/android/CMakeLists.txt
@@ -5,6 +5,12 @@
## tst_android Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_android LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_android
SOURCES
tst_android.cpp
@@ -12,6 +18,7 @@ qt_internal_add_test(tst_android
Qt::CorePrivate
Qt::Gui
Qt::GuiPrivate
+ Qt::Widgets
)
if(ANDROID)