summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/plugin/qlibrary/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/plugin/qlibrary/lib/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/plugin/qlibrary/lib/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/corelib/plugin/qlibrary/lib/CMakeLists.txt b/tests/auto/corelib/plugin/qlibrary/lib/CMakeLists.txt
index f2de91635a..f3480200cc 100644
--- a/tests/auto/corelib/plugin/qlibrary/lib/CMakeLists.txt
+++ b/tests/auto/corelib/plugin/qlibrary/lib/CMakeLists.txt
@@ -21,6 +21,12 @@ set_target_properties(mylib PROPERTIES
C_VISIBILITY_PRESET "default"
CXX_VISIBILITY_PRESET "default"
)
+
+if(WIN32)
+ # CMake sets for Windows-GNU platforms the suffix "lib"
+ set_property(TARGET mylib PROPERTY PREFIX "")
+endif()
+
# special case end
#### Keys ignored in scope 1:.:.:lib.pro:<TRUE>: