summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/plugin/qplugin/debugplugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/plugin/qplugin/debugplugin/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/plugin/qplugin/debugplugin/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/tests/auto/corelib/plugin/qplugin/debugplugin/CMakeLists.txt b/tests/auto/corelib/plugin/qplugin/debugplugin/CMakeLists.txt
index 5b9a21cb3b..ab32e5e364 100644
--- a/tests/auto/corelib/plugin/qplugin/debugplugin/CMakeLists.txt
+++ b/tests/auto/corelib/plugin/qplugin/debugplugin/CMakeLists.txt
@@ -1,11 +1,11 @@
# Generated from debugplugin.pro.
#####################################################################
-## debugplugin Plugin:
+## debugplugin Generic Library:
#####################################################################
-add_qt_plugin(debugplugin
- SKIP_INSTALL
+add_cmake_library(debugplugin
+ MODULE
OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../plugins"
SOURCES
main.cpp
@@ -15,3 +15,5 @@ add_qt_plugin(debugplugin
#### Keys ignored in scope 1:.:.:debugplugin.pro:<TRUE>:
# TEMPLATE = "lib"
+
+qt_autogen_tools_initial_setup(debugplugin)