summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/plugin/qpluginloader/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/plugin/qpluginloader/lib/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/plugin/qpluginloader/lib/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/auto/corelib/plugin/qpluginloader/lib/CMakeLists.txt b/tests/auto/corelib/plugin/qpluginloader/lib/CMakeLists.txt
index aa980eabaa..c547b75592 100644
--- a/tests/auto/corelib/plugin/qpluginloader/lib/CMakeLists.txt
+++ b/tests/auto/corelib/plugin/qpluginloader/lib/CMakeLists.txt
@@ -14,6 +14,13 @@ add_cmake_library(tst_qpluginloaderlib
Qt::Core
)
+# special case begin
+if(WIN32)
+ # CMake sets for Windows-GNU platforms the suffix "lib"
+ set_property(TARGET tst_qpluginloaderlib PROPERTY PREFIX "")
+endif()
+# special case begin
+
#### Keys ignored in scope 1:.:.:lib.pro:<TRUE>:
# INSTALLS = "target"
# TEMPLATE = "lib"