summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/text/qbytearray/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/text/qbytearray/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/text/qbytearray/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/auto/corelib/text/qbytearray/CMakeLists.txt b/tests/auto/corelib/text/qbytearray/CMakeLists.txt
new file mode 100644
index 0000000000..34307d9d44
--- /dev/null
+++ b/tests/auto/corelib/text/qbytearray/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## tst_qbytearray Test:
+#####################################################################
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qbytearray LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qbytearray
+ SOURCES
+ tst_qbytearray.cpp
+ LIBRARIES
+ Qt::CorePrivate
+)
+
+## Scopes:
+#####################################################################
+
+qt_internal_extend_target(tst_qbytearray CONDITION APPLE
+ SOURCES
+ tst_qbytearray_mac.mm
+ LIBRARIES
+ ${FWFoundation}
+)