summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/text/qbytearray/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/text/qbytearray/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/text/qbytearray/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/tests/auto/corelib/text/qbytearray/CMakeLists.txt b/tests/auto/corelib/text/qbytearray/CMakeLists.txt
index b1679c72f3..34307d9d44 100644
--- a/tests/auto/corelib/text/qbytearray/CMakeLists.txt
+++ b/tests/auto/corelib/text/qbytearray/CMakeLists.txt
@@ -1,21 +1,21 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# Generated from qbytearray.pro.
-
#####################################################################
## tst_qbytearray Test:
#####################################################################
-# Collect test data
-list(APPEND test_data "rfc3252.txt")
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qbytearray LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
qt_internal_add_test(tst_qbytearray
SOURCES
tst_qbytearray.cpp
LIBRARIES
Qt::CorePrivate
- TESTDATA ${test_data}
)
## Scopes: