summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/text/qlocale/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/text/qlocale/test/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/text/qlocale/test/CMakeLists.txt20
1 files changed, 12 insertions, 8 deletions
diff --git a/tests/auto/corelib/text/qlocale/test/CMakeLists.txt b/tests/auto/corelib/text/qlocale/test/CMakeLists.txt
index 399b22327e..fc3e1488cd 100644
--- a/tests/auto/corelib/text/qlocale/test/CMakeLists.txt
+++ b/tests/auto/corelib/text/qlocale/test/CMakeLists.txt
@@ -1,29 +1,33 @@
-# Generated from test.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qlocale Test:
#####################################################################
-qt_add_test(tst_qlocale
+qt_internal_add_test(tst_qlocale
OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../"
SOURCES
../tst_qlocale.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
+ Qt::TestPrivate
)
## Scopes:
#####################################################################
-qt_extend_target(tst_qlocale CONDITION embedded
- PUBLIC_LIBRARIES
+qt_internal_extend_target(tst_qlocale CONDITION embedded
+ LIBRARIES
Qt::Gui
)
-qt_extend_target(tst_qlocale CONDITION NOT QT_FEATURE_doubleconversion AND NOT QT_FEATURE_system_doubleconversion
+qt_internal_extend_target(tst_qlocale CONDITION NOT QT_FEATURE_doubleconversion AND NOT QT_FEATURE_system_doubleconversion
DEFINES
QT_NO_DOUBLECONVERSION
)
-#### Keys ignored in scope 7:.:.:test.pro:NOT ANDROID:
-# TEST_HELPER_INSTALLS = "../syslocaleapp/syslocaleapp"
+## Depends on ../syslocaleapp
+if(QT_FEATURE_process)
+ add_dependencies(tst_qlocale syslocaleapp)
+endif()