summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/text/qlocale/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/text/qlocale/test/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/text/qlocale/test/CMakeLists.txt14
1 files changed, 9 insertions, 5 deletions
diff --git a/tests/auto/corelib/text/qlocale/test/CMakeLists.txt b/tests/auto/corelib/text/qlocale/test/CMakeLists.txt
index 863252cf77..fc3e1488cd 100644
--- a/tests/auto/corelib/text/qlocale/test/CMakeLists.txt
+++ b/tests/auto/corelib/text/qlocale/test/CMakeLists.txt
@@ -1,4 +1,5 @@
-# Generated from test.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qlocale Test:
@@ -8,15 +9,16 @@ qt_internal_add_test(tst_qlocale
OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../"
SOURCES
../tst_qlocale.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
+ Qt::TestPrivate
)
## Scopes:
#####################################################################
qt_internal_extend_target(tst_qlocale CONDITION embedded
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Gui
)
@@ -25,5 +27,7 @@ qt_internal_extend_target(tst_qlocale CONDITION NOT QT_FEATURE_doubleconversion
QT_NO_DOUBLECONVERSION
)
-#### Keys ignored in scope 7:.:.:test.pro:NOT ANDROID:
-# TEST_HELPER_INSTALLS = "../syslocaleapp/syslocaleapp"
+## Depends on ../syslocaleapp
+if(QT_FEATURE_process)
+ add_dependencies(tst_qlocale syslocaleapp)
+endif()