summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/text/qlocale/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/text/qlocale/test/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/text/qlocale/test/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/auto/corelib/text/qlocale/test/CMakeLists.txt b/tests/auto/corelib/text/qlocale/test/CMakeLists.txt
new file mode 100644
index 0000000000..19d454d530
--- /dev/null
+++ b/tests/auto/corelib/text/qlocale/test/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Generated from test.pro.
+
+#####################################################################
+## tst_qlocale Test:
+#####################################################################
+
+qt_add_test(tst_qlocale
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../"
+ SOURCES
+ ../tst_qlocale.cpp
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+)
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(tst_qlocale CONDITION embedded
+ PUBLIC_LIBRARIES
+ Qt::Gui
+)
+
+qt_extend_target(tst_qlocale CONDITION NOT QT_FEATURE_doubleconversion AND NOT QT_FEATURE_system_doubleconversion
+ DEFINES
+ QT_NO_DOUBLECONVERSION
+)
+
+#### Keys ignored in scope 7:.:.:test.pro:NOT ANDROID AND NOT WINRT:
+# TEST_HELPER_INSTALLS = "../syslocaleapp/syslocaleapp"