summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/tools/qoffsetstringarray/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/tools/qoffsetstringarray/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/tools/qoffsetstringarray/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/auto/corelib/tools/qoffsetstringarray/CMakeLists.txt b/tests/auto/corelib/tools/qoffsetstringarray/CMakeLists.txt
index 7584d580ec..67dffe0284 100644
--- a/tests/auto/corelib/tools/qoffsetstringarray/CMakeLists.txt
+++ b/tests/auto/corelib/tools/qoffsetstringarray/CMakeLists.txt
@@ -10,3 +10,10 @@ qt_internal_add_test(tst_qoffsetstringarray
PUBLIC_LIBRARIES
Qt::CorePrivate
)
+
+if (CLANG)
+ target_compile_options(tst_qoffsetstringarray
+ PUBLIC -fbracket-depth=512)
+elseif (GCC)
+ # fconstexpr-depth= defaults to 512
+endif()