summaryrefslogtreecommitdiffstats
path: root/tests/auto/dbus/qdbusinterface/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/dbus/qdbusinterface/CMakeLists.txt')
-rw-r--r--tests/auto/dbus/qdbusinterface/CMakeLists.txt27
1 files changed, 15 insertions, 12 deletions
diff --git a/tests/auto/dbus/qdbusinterface/CMakeLists.txt b/tests/auto/dbus/qdbusinterface/CMakeLists.txt
index 321c61a627..56439f9ef6 100644
--- a/tests/auto/dbus/qdbusinterface/CMakeLists.txt
+++ b/tests/auto/dbus/qdbusinterface/CMakeLists.txt
@@ -1,41 +1,44 @@
-# Generated from qdbusinterface.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qdbusinterface LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
add_subdirectory(qmyserver)
-# special case begin
#####################################################################
## ../tst_qdbusinterface Test:
#####################################################################
-add_qt_test(tst_qdbusinterface
+qt_internal_add_test(tst_qdbusinterface
SOURCES
myobject.h
tst_qdbusinterface.cpp
LIBRARIES
Qt::CorePrivate
Qt::DBusPrivate
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Core
Qt::DBus
)
-#### Keys ignored in scope 1:.:.:qdbusinterface.pro:<TRUE>:
-# CONFIG = "testcase"
-# DESTDIR = "./"
-
## Scopes:
#####################################################################
-extend_target(tst_qdbusinterface CONDITION QT_FEATURE_dbus_linked
+qt_internal_extend_target(tst_qdbusinterface CONDITION QT_FEATURE_dbus_linked
DEFINES
QT_LINKED_LIBDBUS
- PUBLIC_LIBRARIES
+ LIBRARIES
dbus-1
)
-extend_target(tst_qdbusinterface CONDITION NOT QT_FEATURE_dbus_linked
+qt_internal_extend_target(tst_qdbusinterface CONDITION NOT QT_FEATURE_dbus_linked
SOURCES
../../../../src/dbus/qdbus_symbols.cpp
)
-# special case end
+add_dependencies(tst_qdbusinterface qmyserver_qdbusinterface)
+