summaryrefslogtreecommitdiffstats
path: root/tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt')
-rw-r--r--tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt b/tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt
index 627b29ff42..bbbe1e8633 100644
--- a/tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt
+++ b/tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt
@@ -4,10 +4,16 @@
## qmyserver Binary:
#####################################################################
-add_qt_executable(qmyserver
+# Can't be called qmyserver since the qdbusabstractadaptor test
+# already has a executable target named like that, so use
+# a different target name and then rename the binary
+add_qt_executable(qmyserver_qdbusinterface
SOURCES
../myobject.h
qmyserver.cpp
LIBRARIES
+ Qt::Core
Qt::DBus
)
+
+set_target_properties(qmyserver_qdbusinterface PROPERTIES OUTPUT_NAME qmyserver)