summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/image/qpixmap/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/gui/image/qpixmap/CMakeLists.txt')
-rw-r--r--tests/auto/gui/image/qpixmap/CMakeLists.txt23
1 files changed, 15 insertions, 8 deletions
diff --git a/tests/auto/gui/image/qpixmap/CMakeLists.txt b/tests/auto/gui/image/qpixmap/CMakeLists.txt
index b58609a760..8531ef5b7b 100644
--- a/tests/auto/gui/image/qpixmap/CMakeLists.txt
+++ b/tests/auto/gui/image/qpixmap/CMakeLists.txt
@@ -1,9 +1,16 @@
-# Generated from qpixmap.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qpixmap Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qpixmap LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
# Collect test data
file(GLOB_RECURSE test_data_glob
RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
@@ -22,10 +29,10 @@ file(GLOB_RECURSE test_data_glob
images/*)
list(APPEND test_data ${test_data_glob})
-qt_add_test(tst_qpixmap
+qt_internal_add_test(tst_qpixmap
SOURCES
tst_qpixmap.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
Qt::Gui
Qt::GuiPrivate
@@ -83,7 +90,7 @@ set(qpixmap_resource_files
"loadFromData/designer_rgb32.png"
)
-qt_add_resource(tst_qpixmap "qpixmap"
+qt_internal_add_resource(tst_qpixmap "qpixmap"
PREFIX
"/"
FILES
@@ -94,14 +101,14 @@ qt_add_resource(tst_qpixmap "qpixmap"
## Scopes:
#####################################################################
-qt_extend_target(tst_qpixmap CONDITION TARGET Qt::Widgets
- PUBLIC_LIBRARIES
+qt_internal_extend_target(tst_qpixmap CONDITION TARGET Qt::Widgets
+ LIBRARIES
Qt::Widgets
Qt::WidgetsPrivate
)
-qt_extend_target(tst_qpixmap CONDITION WIN32
- PUBLIC_LIBRARIES
+qt_internal_extend_target(tst_qpixmap CONDITION WIN32
+ LIBRARIES
gdi32
user32
)