summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/kernel/qguieventloop/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/gui/kernel/qguieventloop/CMakeLists.txt')
-rw-r--r--tests/auto/gui/kernel/qguieventloop/CMakeLists.txt13
1 files changed, 10 insertions, 3 deletions
diff --git a/tests/auto/gui/kernel/qguieventloop/CMakeLists.txt b/tests/auto/gui/kernel/qguieventloop/CMakeLists.txt
index ec9441a1dc..89c518be10 100644
--- a/tests/auto/gui/kernel/qguieventloop/CMakeLists.txt
+++ b/tests/auto/gui/kernel/qguieventloop/CMakeLists.txt
@@ -1,13 +1,20 @@
-# Generated from qguieventloop.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qguieventloop Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qguieventloop LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qguieventloop
SOURCES
../../../corelib/kernel/qeventloop/tst_qeventloop.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
Qt::Gui
Qt::Network
@@ -17,7 +24,7 @@ qt_internal_add_test(tst_qguieventloop
#####################################################################
qt_internal_extend_target(tst_qguieventloop CONDITION WIN32
- PUBLIC_LIBRARIES
+ LIBRARIES
user32
)