summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/kernel/qwindow/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/gui/kernel/qwindow/CMakeLists.txt')
-rw-r--r--tests/auto/gui/kernel/qwindow/CMakeLists.txt16
1 files changed, 14 insertions, 2 deletions
diff --git a/tests/auto/gui/kernel/qwindow/CMakeLists.txt b/tests/auto/gui/kernel/qwindow/CMakeLists.txt
index 605761622f..5824989ac3 100644
--- a/tests/auto/gui/kernel/qwindow/CMakeLists.txt
+++ b/tests/auto/gui/kernel/qwindow/CMakeLists.txt
@@ -5,6 +5,12 @@
## tst_qwindow Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qwindow LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qwindow
SOURCES
tst_qwindow.cpp
@@ -14,8 +20,9 @@ qt_internal_add_test(tst_qwindow
Qt::GuiPrivate
)
-if(APPLE OR WIN32)
+if(APPLE OR WIN32 OR QT_FEATURE_xcb)
qt_internal_add_test(tst_foreignwindow
+ LOWDPI
SOURCES
tst_foreignwindow.cpp
LIBRARIES
@@ -25,9 +32,14 @@ if(APPLE OR WIN32)
)
if(APPLE)
- target_compile_options(tst_foreignwindow PRIVATE -x objective-c++)
+ enable_language(OBJCXX)
+ set_source_files_properties(tst_foreignwindow.cpp PROPERTIES LANGUAGE OBJCXX)
set_property(TARGET tst_foreignwindow PROPERTY PROPERTY MACOSX_BUNDLE TRUE)
endif()
+
+ if(QT_FEATURE_xcb)
+ target_link_libraries(tst_foreignwindow PRIVATE XCB::XCB)
+ endif()
endif()
## Scopes: