summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/painting/qpageranges/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/gui/painting/qpageranges/CMakeLists.txt')
-rw-r--r--tests/auto/gui/painting/qpageranges/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/auto/gui/painting/qpageranges/CMakeLists.txt b/tests/auto/gui/painting/qpageranges/CMakeLists.txt
new file mode 100644
index 0000000000..99ab477eae
--- /dev/null
+++ b/tests/auto/gui/painting/qpageranges/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## tst_qpageranges Test:
+#####################################################################
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qpageranges LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qpageranges
+ SOURCES
+ tst_qpageranges.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::GuiPrivate
+)