summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/rhi/qrhi/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/gui/rhi/qrhi/CMakeLists.txt')
-rw-r--r--tests/auto/gui/rhi/qrhi/CMakeLists.txt34
1 files changed, 18 insertions, 16 deletions
diff --git a/tests/auto/gui/rhi/qrhi/CMakeLists.txt b/tests/auto/gui/rhi/qrhi/CMakeLists.txt
index 8ea9bf36af..3b0d643060 100644
--- a/tests/auto/gui/rhi/qrhi/CMakeLists.txt
+++ b/tests/auto/gui/rhi/qrhi/CMakeLists.txt
@@ -1,26 +1,28 @@
-# Generated from qrhi.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qrhi Test:
#####################################################################
-qt_add_test(tst_qrhi
- SOURCES
- tst_qrhi.cpp
- PUBLIC_LIBRARIES
- Qt::Gui
- Qt::GuiPrivate
-)
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qrhi LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
# Resources:
-set(qrhi_resource_files
- "data"
+file(GLOB_RECURSE qrhi_resource_files
+ RELATIVE "${CMAKE_CURRENT_SOURCE_DIR}"
+ data/*
)
-qt_add_resource(tst_qrhi "qrhi"
- PREFIX
- "/"
- FILES
- ${qrhi_resource_files}
+qt_internal_add_test(tst_qrhi
+ SOURCES
+ tst_qrhi.cpp
+ LIBRARIES
+ Qt::Gui
+ Qt::GuiPrivate
+ TESTDATA ${qrhi_resource_files}
+ BUILTIN_TESTDATA
)
-