summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/rhi/qshader/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/gui/rhi/qshader/CMakeLists.txt')
-rw-r--r--tests/auto/gui/rhi/qshader/CMakeLists.txt32
1 files changed, 17 insertions, 15 deletions
diff --git a/tests/auto/gui/rhi/qshader/CMakeLists.txt b/tests/auto/gui/rhi/qshader/CMakeLists.txt
index 9a0e246aa4..09bf0d585d 100644
--- a/tests/auto/gui/rhi/qshader/CMakeLists.txt
+++ b/tests/auto/gui/rhi/qshader/CMakeLists.txt
@@ -1,26 +1,28 @@
-# Generated from qshader.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qshader Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qshader LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+# Resources:
+file(GLOB_RECURSE qshader_resource_files
+ RELATIVE "${CMAKE_CURRENT_SOURCE_DIR}"
+ "data/*"
+)
+
qt_internal_add_test(tst_qshader
SOURCES
tst_qshader.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Gui
Qt::GuiPrivate
+ TESTDATA ${qshader_resource_files}
+ BUILTIN_TESTDATA
)
-
-# Resources:
-set(qshader_resource_files
- "data"
-)
-
-qt_internal_add_resource(tst_qshader "qshader"
- PREFIX
- "/"
- FILES
- ${qshader_resource_files}
-)
-