summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/text/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/gui/text/CMakeLists.txt')
-rw-r--r--tests/auto/gui/text/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/auto/gui/text/CMakeLists.txt b/tests/auto/gui/text/CMakeLists.txt
index 5040060a33..b7262f7c00 100644
--- a/tests/auto/gui/text/CMakeLists.txt
+++ b/tests/auto/gui/text/CMakeLists.txt
@@ -27,7 +27,8 @@ if(QT_FEATURE_private_tests)
add_subdirectory(qzip)
add_subdirectory(qtextodfwriter)
endif()
-if(TARGET Qt::Xml)
+# QTBUG-87671 # special case
+if(TARGET Qt::Xml AND NOT ANDROID)
add_subdirectory(qtextdocument)
endif()
if(QT_FEATURE_private_tests AND UNIX)