summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/text/qfont/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/gui/text/qfont/CMakeLists.txt')
-rw-r--r--tests/auto/gui/text/qfont/CMakeLists.txt34
1 files changed, 18 insertions, 16 deletions
diff --git a/tests/auto/gui/text/qfont/CMakeLists.txt b/tests/auto/gui/text/qfont/CMakeLists.txt
index 05c6ca8270..88ae9959e4 100644
--- a/tests/auto/gui/text/qfont/CMakeLists.txt
+++ b/tests/auto/gui/text/qfont/CMakeLists.txt
@@ -1,36 +1,38 @@
-# Generated from qfont.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qfont Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qfont LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+# Resources:
+set(testfont_resource_files
+ "datastream.515"
+ "weirdfont.otf"
+)
+
qt_internal_add_test(tst_qfont
SOURCES
tst_qfont.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
Qt::Gui
Qt::GuiPrivate
Qt::TestPrivate
+ TESTDATA ${testfont_resource_files}
+ BUILTIN_TESTDATA
)
-# Resources:
-set(testfont_resource_files
- "weirdfont.otf"
-)
-
-qt_internal_add_resource(tst_qfont "testfont"
- PREFIX
- "/"
- FILES
- ${testfont_resource_files}
-)
-
-
## Scopes:
#####################################################################
qt_internal_extend_target(tst_qfont CONDITION TARGET Qt::Widgets
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Widgets
)