summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/text/qglyphrun/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/gui/text/qglyphrun/CMakeLists.txt')
-rw-r--r--tests/auto/gui/text/qglyphrun/CMakeLists.txt27
1 files changed, 15 insertions, 12 deletions
diff --git a/tests/auto/gui/text/qglyphrun/CMakeLists.txt b/tests/auto/gui/text/qglyphrun/CMakeLists.txt
index b0585af16f..a9ffd3729d 100644
--- a/tests/auto/gui/text/qglyphrun/CMakeLists.txt
+++ b/tests/auto/gui/text/qglyphrun/CMakeLists.txt
@@ -1,15 +1,15 @@
-# Generated from qglyphrun.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qglyphrun Test:
#####################################################################
-qt_internal_add_test(tst_qglyphrun
- SOURCES
- tst_qglyphrun.cpp
- PUBLIC_LIBRARIES
- Qt::Gui
-)
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qglyphrun LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
# Resources:
set_source_files_properties("../../../shared/resources/test.ttf"
@@ -17,12 +17,15 @@ set_source_files_properties("../../../shared/resources/test.ttf"
)
set(testdata_resource_files
"../../../shared/resources/test.ttf"
+ "Ligatures.otf"
)
-qt_internal_add_resource(tst_qglyphrun "testdata"
- PREFIX
- "/"
- FILES
- ${testdata_resource_files}
+qt_internal_add_test(tst_qglyphrun
+ SOURCES
+ tst_qglyphrun.cpp
+ LIBRARIES
+ Qt::Gui
+ TESTDATA ${testdata_resource_files}
+ BUILTIN_TESTDATA
)