summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/text/qtextdocumentlayout/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/gui/text/qtextdocumentlayout/CMakeLists.txt')
-rw-r--r--tests/auto/gui/text/qtextdocumentlayout/CMakeLists.txt17
1 files changed, 12 insertions, 5 deletions
diff --git a/tests/auto/gui/text/qtextdocumentlayout/CMakeLists.txt b/tests/auto/gui/text/qtextdocumentlayout/CMakeLists.txt
index 11dda5929e..07386d4e24 100644
--- a/tests/auto/gui/text/qtextdocumentlayout/CMakeLists.txt
+++ b/tests/auto/gui/text/qtextdocumentlayout/CMakeLists.txt
@@ -1,20 +1,27 @@
-# Generated from qtextdocumentlayout.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qtextdocumentlayout Test:
#####################################################################
-qt_add_test(tst_qtextdocumentlayout
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qtextdocumentlayout LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qtextdocumentlayout
SOURCES
tst_qtextdocumentlayout.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Gui
)
## Scopes:
#####################################################################
-qt_extend_target(tst_qtextdocumentlayout CONDITION TARGET Qt::Widgets
- PUBLIC_LIBRARIES
+qt_internal_extend_target(tst_qtextdocumentlayout CONDITION TARGET Qt::Widgets
+ LIBRARIES
Qt::Widgets
)