summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/network/CMakeLists.txt')
-rw-r--r--tests/auto/network/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/auto/network/CMakeLists.txt b/tests/auto/network/CMakeLists.txt
new file mode 100644
index 0000000000..b7ba3de688
--- /dev/null
+++ b/tests/auto/network/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Generated from network.pro.
+# special case begin
+# SSL library include path is not propagated with private tests which results in
+# test not being able to find the ssl header when they are not in the standard
+# include paths
+if (QT_FEATURE_private_tests)
+ if (QT_FEATURE_openssl AND QT_FEATURE_openssl_linked AND QT_FEATURE_ssl)
+ include_directories($<TARGET_PROPERTY:OpenSSL::SSL,INTERFACE_INCLUDE_DIRECTORIES>)
+ endif()
+
+ if (QT_FEATURE_openssl AND QT_FEATURE_ssl AND NOT QT_FEATURE_openssl_linked)
+ include_directories($<TARGET_PROPERTY:${INSTALL_CMAKE_NAMESPACE}::SSL_nolink,INTERFACE_INCLUDE_DIRECTORIES>)
+ endif()
+endif()
+# special case end
+
+add_subdirectory(access)
+add_subdirectory(bearer)
+add_subdirectory(kernel)
+add_subdirectory(ssl)
+add_subdirectory(socket)