summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/access/hsts/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/network/access/hsts/CMakeLists.txt')
-rw-r--r--tests/auto/network/access/hsts/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/network/access/hsts/CMakeLists.txt b/tests/auto/network/access/hsts/CMakeLists.txt
index 4daf91aa44..821a034940 100644
--- a/tests/auto/network/access/hsts/CMakeLists.txt
+++ b/tests/auto/network/access/hsts/CMakeLists.txt
@@ -5,6 +5,12 @@
## tst_qhsts Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qhsts LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qhsts
SOURCES
tst_qhsts.cpp