summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/access/qdecompresshelper/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/network/access/qdecompresshelper/CMakeLists.txt')
-rw-r--r--tests/auto/network/access/qdecompresshelper/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/network/access/qdecompresshelper/CMakeLists.txt b/tests/auto/network/access/qdecompresshelper/CMakeLists.txt
index c62b2be3c5..09317ca3eb 100644
--- a/tests/auto/network/access/qdecompresshelper/CMakeLists.txt
+++ b/tests/auto/network/access/qdecompresshelper/CMakeLists.txt
@@ -5,6 +5,12 @@
## tst_qdecompresshelper Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qdecompresshelper LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qdecompresshelper
SOURCES
gzip.rcc.cpp