summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/access/qhttpnetworkreply/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/network/access/qhttpnetworkreply/CMakeLists.txt')
-rw-r--r--tests/auto/network/access/qhttpnetworkreply/CMakeLists.txt16
1 files changed, 10 insertions, 6 deletions
diff --git a/tests/auto/network/access/qhttpnetworkreply/CMakeLists.txt b/tests/auto/network/access/qhttpnetworkreply/CMakeLists.txt
index f9ba96cf13..b4e4a822ee 100644
--- a/tests/auto/network/access/qhttpnetworkreply/CMakeLists.txt
+++ b/tests/auto/network/access/qhttpnetworkreply/CMakeLists.txt
@@ -1,4 +1,11 @@
-# Generated from qhttpnetworkreply.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qhttpnetworkreply LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
if(NOT QT_FEATURE_private_tests)
return()
@@ -8,13 +15,10 @@ endif()
## tst_qhttpnetworkreply Test:
#####################################################################
-qt_add_test(tst_qhttpnetworkreply
+qt_internal_add_test(tst_qhttpnetworkreply
SOURCES
tst_qhttpnetworkreply.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
Qt::NetworkPrivate
)
-
-#### Keys ignored in scope 1:.:.:qhttpnetworkreply.pro:<TRUE>:
-# _REQUIREMENTS = "qtConfig(private_tests)"