summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/kernel/qhostaddress/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/network/kernel/qhostaddress/CMakeLists.txt')
-rw-r--r--tests/auto/network/kernel/qhostaddress/CMakeLists.txt17
1 files changed, 12 insertions, 5 deletions
diff --git a/tests/auto/network/kernel/qhostaddress/CMakeLists.txt b/tests/auto/network/kernel/qhostaddress/CMakeLists.txt
index c1999c8db2..e11a600b60 100644
--- a/tests/auto/network/kernel/qhostaddress/CMakeLists.txt
+++ b/tests/auto/network/kernel/qhostaddress/CMakeLists.txt
@@ -1,20 +1,27 @@
-# Generated from qhostaddress.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qhostaddress Test:
#####################################################################
-qt_add_test(tst_qhostaddress
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qhostaddress LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qhostaddress
SOURCES
tst_qhostaddress.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::NetworkPrivate
)
## Scopes:
#####################################################################
-qt_extend_target(tst_qhostaddress CONDITION WIN32
- PUBLIC_LIBRARIES
+qt_internal_extend_target(tst_qhostaddress CONDITION WIN32
+ LIBRARIES
ws2_32
)