summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/kernel/qnetworkinterface/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/network/kernel/qnetworkinterface/CMakeLists.txt')
-rw-r--r--tests/auto/network/kernel/qnetworkinterface/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/auto/network/kernel/qnetworkinterface/CMakeLists.txt b/tests/auto/network/kernel/qnetworkinterface/CMakeLists.txt
index b06ef5c3d1..3e5dab63e0 100644
--- a/tests/auto/network/kernel/qnetworkinterface/CMakeLists.txt
+++ b/tests/auto/network/kernel/qnetworkinterface/CMakeLists.txt
@@ -5,10 +5,16 @@
## tst_qnetworkinterface Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qnetworkinterface LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qnetworkinterface
SOURCES
tst_qnetworkinterface.cpp
LIBRARIES
- Qt::Network
+ Qt::NetworkPrivate
QT_TEST_SERVER_LIST "apache2"
)