summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/socket/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/network/socket/CMakeLists.txt')
-rw-r--r--tests/auto/network/socket/CMakeLists.txt16
1 files changed, 10 insertions, 6 deletions
diff --git a/tests/auto/network/socket/CMakeLists.txt b/tests/auto/network/socket/CMakeLists.txt
index b34b2173e6..7136017f39 100644
--- a/tests/auto/network/socket/CMakeLists.txt
+++ b/tests/auto/network/socket/CMakeLists.txt
@@ -1,22 +1,26 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# Generated from socket.pro.
-
if(QT_FEATURE_private_tests)
add_subdirectory(qhttpsocketengine)
add_subdirectory(qtcpsocket)
add_subdirectory(qsocks5socketengine)
add_subdirectory(platformsocketengine)
endif()
-add_subdirectory(qudpsocket)
+if(QT_FEATURE_udpsocket)
+ add_subdirectory(qudpsocket)
+endif()
add_subdirectory(qabstractsocket)
-if(NOT ANDROID)
- # QTBUG-87387 # special case
+if(QT_FEATURE_localserver AND NOT ANDROID)
+ # QTBUG-87387
add_subdirectory(qlocalsocket)
- # QTBUG-87388 # special case
+endif()
+
+if(QT_FEATURE_networkinterface AND NOT ANDROID)
+ # QTBUG-87388
add_subdirectory(qtcpserver)
endif()
+
if(QT_FEATURE_sctp)
add_subdirectory(qsctpsocket)
endif()