summaryrefslogtreecommitdiffstats
path: root/tests/auto/opengl/qglthreads/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/opengl/qglthreads/CMakeLists.txt')
-rw-r--r--tests/auto/opengl/qglthreads/CMakeLists.txt23
1 files changed, 20 insertions, 3 deletions
diff --git a/tests/auto/opengl/qglthreads/CMakeLists.txt b/tests/auto/opengl/qglthreads/CMakeLists.txt
index 0564fe3e6f..b9c47e7ead 100644
--- a/tests/auto/opengl/qglthreads/CMakeLists.txt
+++ b/tests/auto/opengl/qglthreads/CMakeLists.txt
@@ -1,7 +1,24 @@
-add_qt_test("tst_qglthreads" SOURCES tst_qglthreads.cpp tst_qglthreads.h
+# Generated from qglthreads.pro.
+
+if(NOT TARGET Qt::OpenGL)
+ return()
+endif()
+
+#####################################################################
+## tst_qglthreads Test:
+#####################################################################
+
+add_qt_test(tst_qglthreads
+ SOURCES
+ tst_qglthreads.cpp tst_qglthreads.h
LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
Qt::OpenGL
Qt::Widgets
- Qt::GuiPrivate
- Qt::CorePrivate
)
+
+#### Keys ignored in scope 1:.:.:qglthreads.pro:<TRUE>:
+# _REQUIREMENTS = "qtHaveModule(opengl)"