summaryrefslogtreecommitdiffstats
path: root/tests/auto/other/networkselftest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/other/networkselftest/CMakeLists.txt')
-rw-r--r--tests/auto/other/networkselftest/CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/tests/auto/other/networkselftest/CMakeLists.txt b/tests/auto/other/networkselftest/CMakeLists.txt
index 7093ed0160..6491c510f6 100644
--- a/tests/auto/other/networkselftest/CMakeLists.txt
+++ b/tests/auto/other/networkselftest/CMakeLists.txt
@@ -1,13 +1,21 @@
-# Generated from networkselftest.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_networkselftest Test:
#####################################################################
-qt_add_test(tst_networkselftest
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_networkselftest LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_networkselftest
SOURCES
tst_networkselftest.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
Qt::Network
+ QT_TEST_SERVER_LIST "danted" "squid" "apache2" "ftp-proxy" "vsftpd" "cyrus" "echo"
)