summaryrefslogtreecommitdiffstats
path: root/tests/auto/other/qcomplextext/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/other/qcomplextext/CMakeLists.txt')
-rw-r--r--tests/auto/other/qcomplextext/CMakeLists.txt17
1 files changed, 12 insertions, 5 deletions
diff --git a/tests/auto/other/qcomplextext/CMakeLists.txt b/tests/auto/other/qcomplextext/CMakeLists.txt
index 2b5f951267..74996c7ad7 100644
--- a/tests/auto/other/qcomplextext/CMakeLists.txt
+++ b/tests/auto/other/qcomplextext/CMakeLists.txt
@@ -1,16 +1,23 @@
-# Generated from qcomplextext.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qcomplextext Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qcomplextext LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
# Collect test data
list(APPEND test_data "data")
-qt_add_test(tst_qcomplextext
+qt_internal_add_test(tst_qcomplextext
SOURCES
tst_qcomplextext.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
Qt::Gui
Qt::GuiPrivate
@@ -27,7 +34,7 @@ if(ANDROID)
"data/BidiTest.txt"
)
- qt_add_resource(tst_qcomplextext "android_testdata"
+ qt_internal_add_resource(tst_qcomplextext "android_testdata"
PREFIX
"/android_testdata"
FILES
@@ -35,7 +42,7 @@ if(ANDROID)
)
endif()
-qt_extend_target(tst_qcomplextext CONDITION builtin_testdata
+qt_internal_extend_target(tst_qcomplextext CONDITION builtin_testdata
DEFINES
BUILTIN_TESTDATA
)