summaryrefslogtreecommitdiffstats
path: root/tests/auto/sql/kernel/qsqlfield/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/sql/kernel/qsqlfield/CMakeLists.txt')
-rw-r--r--tests/auto/sql/kernel/qsqlfield/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/sql/kernel/qsqlfield/CMakeLists.txt b/tests/auto/sql/kernel/qsqlfield/CMakeLists.txt
index 9e04209c0a..2fef227201 100644
--- a/tests/auto/sql/kernel/qsqlfield/CMakeLists.txt
+++ b/tests/auto/sql/kernel/qsqlfield/CMakeLists.txt
@@ -5,6 +5,12 @@
## tst_qsqlfield Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qsqlfield LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qsqlfield
SOURCES
tst_qsqlfield.cpp