summaryrefslogtreecommitdiffstats
path: root/tests/auto/sql/kernel/qsqlindex/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/sql/kernel/qsqlindex/CMakeLists.txt')
-rw-r--r--tests/auto/sql/kernel/qsqlindex/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/auto/sql/kernel/qsqlindex/CMakeLists.txt b/tests/auto/sql/kernel/qsqlindex/CMakeLists.txt
new file mode 100644
index 0000000000..3373948b5f
--- /dev/null
+++ b/tests/auto/sql/kernel/qsqlindex/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## tst_qsqlindex Test:
+#####################################################################
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qsqlindex LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qsqlindex
+ SOURCES
+ tst_qsqlindex.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::Sql
+ Qt::SqlPrivate
+)