summaryrefslogtreecommitdiffstats
path: root/tests/auto/testlib/selftests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/testlib/selftests/CMakeLists.txt')
-rw-r--r--tests/auto/testlib/selftests/CMakeLists.txt65
1 files changed, 55 insertions, 10 deletions
diff --git a/tests/auto/testlib/selftests/CMakeLists.txt b/tests/auto/testlib/selftests/CMakeLists.txt
index a1f6cd5457..4126014efd 100644
--- a/tests/auto/testlib/selftests/CMakeLists.txt
+++ b/tests/auto/testlib/selftests/CMakeLists.txt
@@ -1,19 +1,64 @@
-# Generated from selftests.pro.
+# The whole file is written manually.
+# special case skip regeneration
-# special case begin
include(../../../../src/testlib/selfcover.cmake)
-# special case end
-add_subdirectory(test)
+# ------------- Test runner -------------
-if(NOT WINRT)
+qt_add_test(tst_selftests
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/"
+ SOURCES
+ ../../../shared/emulationdetector.h
+ tst_selftests.cpp
+ INCLUDE_DIRECTORIES
+ ../../../shared
+ PUBLIC_LIBRARIES
+ Qt::TestPrivate
+ # special case begin
+ # These lines need to be commented out as they need to be enabled
+ # COMPILE_OPTIONS
+ # conditionally
+ # --cs-exclude-file-abs-wildcard=${QT_SOURCE_TREE}/*
+ # --cs-include-file-abs-wildcard=*/src/testlib/*
+ # --cs-mcc
+ # --cs-mcdc
+ # LINK_OPTIONS
+ # "$$COVERAGE_OPTIONS"
+ # special case end
+)
- if(TARGET Qt::Gui)
- endif()
-endif()
-# special case begin
+file(GLOB resource_glob_0 RELATIVE "${CMAKE_CURRENT_SOURCE_DIR}" "expected_*")
+foreach(file IN LISTS resource_glob_0)
+ set_source_files_properties("${CMAKE_CURRENT_SOURCE_DIR}/${file}" PROPERTIES QT_RESOURCE_ALIAS "${file}")
+endforeach()
-# The whole file is written manually.
+# Resources:
+set(qmake_expected_files_resource_files
+ ${resource_glob_0}
+)
+
+qt_add_resource(tst_selftests "qmake_expected_files"
+ PREFIX
+ "/"
+ BASE
+ "${CMAKE_CURRENT_SOURCE_DIR}" # special case
+ FILES
+ ${qmake_expected_files_resource_files}
+)
+
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 5:.:.:test.pro:NOT ANDROID AND NOT WINRT AND for(file,SUBPROGRAMS):
+# TEST_HELPER_INSTALLS = "../$${file}/$${file}"
+
+#### Keys ignored in scope 7:.:..:../selftests.pri:TARGET Qt::Gui:
+# SUBPROGRAMS = "keyboard" "mouse"
+
+qt_apply_testlib_coverage_options(tst_selftests)
+
+# ------------- Sub tests -------------
if(NOT WINRT)
add_subdirectory(assert)