summaryrefslogtreecommitdiffstats
path: root/tests/auto/testlib/selftests/cmptest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/testlib/selftests/cmptest/CMakeLists.txt')
-rw-r--r--tests/auto/testlib/selftests/cmptest/CMakeLists.txt20
1 files changed, 10 insertions, 10 deletions
diff --git a/tests/auto/testlib/selftests/cmptest/CMakeLists.txt b/tests/auto/testlib/selftests/cmptest/CMakeLists.txt
index 336fb01e74..67700db36e 100644
--- a/tests/auto/testlib/selftests/cmptest/CMakeLists.txt
+++ b/tests/auto/testlib/selftests/cmptest/CMakeLists.txt
@@ -1,26 +1,26 @@
-# Generated from cmptest.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## cmptest Binary:
#####################################################################
-qt_add_executable(cmptest
- NO_INSTALL # special case
- OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} # special case
+qt_internal_add_executable(cmptest
+ NO_INSTALL
+ EXCEPTIONS
+ OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
SOURCES
tst_cmptest.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Test
)
## Scopes:
#####################################################################
-qt_extend_target(cmptest CONDITION TARGET Qt::Gui
- PUBLIC_LIBRARIES
+qt_internal_extend_target(cmptest CONDITION TARGET Qt::Gui
+ LIBRARIES
Qt::Gui
)
-# special case begin
-qt_apply_testlib_coverage_options(cmptest)
-# special case end
+qt_internal_apply_testlib_coverage_options(cmptest)