summaryrefslogtreecommitdiffstats
path: root/tests/auto/testlib/selftests/float/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/testlib/selftests/float/CMakeLists.txt')
-rw-r--r--tests/auto/testlib/selftests/float/CMakeLists.txt16
1 files changed, 7 insertions, 9 deletions
diff --git a/tests/auto/testlib/selftests/float/CMakeLists.txt b/tests/auto/testlib/selftests/float/CMakeLists.txt
index 375cfe1e65..448c3e962e 100644
--- a/tests/auto/testlib/selftests/float/CMakeLists.txt
+++ b/tests/auto/testlib/selftests/float/CMakeLists.txt
@@ -1,24 +1,22 @@
-# Generated from float.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## float Binary:
#####################################################################
qt_internal_add_executable(float
- NO_INSTALL # special case
- OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} # special case
+ NO_INSTALL
+ EXCEPTIONS
+ OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
SOURCES
- ../../../../shared/emulationdetector.h
tst_float.cpp
- INCLUDE_DIRECTORIES
- ../../../../shared
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Test
+ Qt::TestPrivate
)
## Scopes:
#####################################################################
-# special case begin
qt_internal_apply_testlib_coverage_options(float)
-# special case end