summaryrefslogtreecommitdiffstats
path: root/tests/auto/testlib/selftests/junit/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/testlib/selftests/junit/CMakeLists.txt')
-rw-r--r--tests/auto/testlib/selftests/junit/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/auto/testlib/selftests/junit/CMakeLists.txt b/tests/auto/testlib/selftests/junit/CMakeLists.txt
new file mode 100644
index 0000000000..a736d2a15c
--- /dev/null
+++ b/tests/auto/testlib/selftests/junit/CMakeLists.txt
@@ -0,0 +1,14 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_executable(junit
+ NO_INSTALL
+ EXCEPTIONS
+ OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+ SOURCES
+ tst_junit.cpp
+ LIBRARIES
+ Qt::Test
+)
+
+qt_internal_apply_testlib_coverage_options(junit)