summaryrefslogtreecommitdiffstats
path: root/tests/auto/testlib/selftests/sleep/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/testlib/selftests/sleep/CMakeLists.txt')
-rw-r--r--tests/auto/testlib/selftests/sleep/CMakeLists.txt13
1 files changed, 7 insertions, 6 deletions
diff --git a/tests/auto/testlib/selftests/sleep/CMakeLists.txt b/tests/auto/testlib/selftests/sleep/CMakeLists.txt
index 418c61bab9..2e789b59d7 100644
--- a/tests/auto/testlib/selftests/sleep/CMakeLists.txt
+++ b/tests/auto/testlib/selftests/sleep/CMakeLists.txt
@@ -1,21 +1,22 @@
-# Generated from sleep.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## sleep Binary:
#####################################################################
qt_internal_add_executable(sleep
- NO_INSTALL # special case
- OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} # special case
+ NO_INSTALL
+ EXCEPTIONS
+ OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
SOURCES
tst_sleep.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Test
+ Qt::CorePrivate
)
## Scopes:
#####################################################################
-# special case begin
qt_internal_apply_testlib_coverage_options(sleep)
-# special case end