summaryrefslogtreecommitdiffstats
path: root/tests/auto/testlib/selftests/subtest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/testlib/selftests/subtest/CMakeLists.txt')
-rw-r--r--tests/auto/testlib/selftests/subtest/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/tests/auto/testlib/selftests/subtest/CMakeLists.txt b/tests/auto/testlib/selftests/subtest/CMakeLists.txt
index e27c3a1b4a..3dad026cf3 100644
--- a/tests/auto/testlib/selftests/subtest/CMakeLists.txt
+++ b/tests/auto/testlib/selftests/subtest/CMakeLists.txt
@@ -1,21 +1,21 @@
-# Generated from subtest.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## subtest Binary:
#####################################################################
-qt_add_executable(subtest
- NO_INSTALL # special case
- OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} # special case
+qt_internal_add_executable(subtest
+ NO_INSTALL
+ EXCEPTIONS
+ OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
SOURCES
tst_subtest.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Test
)
## Scopes:
#####################################################################
-# special case begin
-qt_apply_testlib_coverage_options(subtest)
-# special case end
+qt_internal_apply_testlib_coverage_options(subtest)