summaryrefslogtreecommitdiffstats
path: root/tests/auto/testlib/tostring/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/testlib/tostring/CMakeLists.txt')
-rw-r--r--tests/auto/testlib/tostring/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/auto/testlib/tostring/CMakeLists.txt b/tests/auto/testlib/tostring/CMakeLists.txt
new file mode 100644
index 0000000000..cb0bdff847
--- /dev/null
+++ b/tests/auto/testlib/tostring/CMakeLists.txt
@@ -0,0 +1,13 @@
+# Copyright (C) 2023 Intel Corporation.
+# SPDX-License-Identifier: BSD-3-Clause
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_tostring LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_tostring
+ SOURCES
+ tst_tostring.cpp
+)