summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/tools/CMakeLists.txt')
-rw-r--r--tests/auto/tools/CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/tests/auto/tools/CMakeLists.txt b/tests/auto/tools/CMakeLists.txt
index 9e59771aa0..ffeb228cf3 100644
--- a/tests/auto/tools/CMakeLists.txt
+++ b/tests/auto/tools/CMakeLists.txt
@@ -1,9 +1,7 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# Generated from tools.pro.
-
-# QTBUG-88538 # special case
+# QTBUG-88538
if(NOT ANDROID AND NOT IOS)
add_subdirectory(qmakelib)
if(QT_FEATURE_qmake)
@@ -11,12 +9,13 @@ if(NOT ANDROID AND NOT IOS)
endif()
add_subdirectory(moc)
add_subdirectory(rcc)
+ add_subdirectory(qt_cmake_create)
endif()
-# QTBUG-88538 # special case
+# QTBUG-88538
if(TARGET Qt::Widgets AND NOT ANDROID AND NOT IOS)
add_subdirectory(uic)
endif()
-if(TARGET Qt::DBus)
+if(run_dbus_tests)
add_subdirectory(qdbuscpp2xml)
add_subdirectory(qdbusxml2cpp)
endif()