summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/tools/CMakeLists.txt')
-rw-r--r--tests/auto/tools/CMakeLists.txt24
1 files changed, 19 insertions, 5 deletions
diff --git a/tests/auto/tools/CMakeLists.txt b/tests/auto/tools/CMakeLists.txt
index f1a9ced60e..ffeb228cf3 100644
--- a/tests/auto/tools/CMakeLists.txt
+++ b/tests/auto/tools/CMakeLists.txt
@@ -1,17 +1,31 @@
-# Generated from tools.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
-# QTBUG-88538 # special case
+# QTBUG-88538
if(NOT ANDROID AND NOT IOS)
add_subdirectory(qmakelib)
- add_subdirectory(qmake)
+ if(QT_FEATURE_qmake)
+ add_subdirectory(qmake)
+ endif()
add_subdirectory(moc)
add_subdirectory(rcc)
+ add_subdirectory(qt_cmake_create)
endif()
-# QTBUG-88538 # special case
+# QTBUG-88538
if(TARGET Qt::Widgets AND NOT ANDROID AND NOT IOS)
add_subdirectory(uic)
endif()
-if(TARGET Qt::DBus)
+if(run_dbus_tests)
add_subdirectory(qdbuscpp2xml)
add_subdirectory(qdbusxml2cpp)
endif()
+if(TARGET Qt::Gui AND QT_FEATURE_process AND NOT CMAKE_CROSSCOMPILING)
+ # testapp (windeployqt) and source_basicapp (macdeployqt) require QtGui.
+ if(QT_FEATURE_macdeployqt)
+ add_subdirectory(macdeployqt)
+ endif()
+ if(QT_FEATURE_windeployqt AND BUILD_SHARED_LIBS)
+ # windeployqt does not work with static Qt builds. See QTBUG-69427.
+ add_subdirectory(windeployqt)
+ endif()
+endif()