summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/tools/CMakeLists.txt')
-rw-r--r--tests/auto/tools/CMakeLists.txt14
1 files changed, 9 insertions, 5 deletions
diff --git a/tests/auto/tools/CMakeLists.txt b/tests/auto/tools/CMakeLists.txt
index d6cc753db7..f1a9ced60e 100644
--- a/tests/auto/tools/CMakeLists.txt
+++ b/tests/auto/tools/CMakeLists.txt
@@ -1,10 +1,14 @@
# Generated from tools.pro.
-add_subdirectory(qmakelib)
-add_subdirectory(qmake)
-add_subdirectory(moc)
-add_subdirectory(rcc)
-if(TARGET Qt::Widgets)
+# QTBUG-88538 # special case
+if(NOT ANDROID AND NOT IOS)
+ add_subdirectory(qmakelib)
+ add_subdirectory(qmake)
+ add_subdirectory(moc)
+ add_subdirectory(rcc)
+endif()
+# QTBUG-88538 # special case
+if(TARGET Qt::Widgets AND NOT ANDROID AND NOT IOS)
add_subdirectory(uic)
endif()
if(TARGET Qt::DBus)