summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/macdeployqt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/tools/macdeployqt/CMakeLists.txt')
-rw-r--r--tests/auto/tools/macdeployqt/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/auto/tools/macdeployqt/CMakeLists.txt b/tests/auto/tools/macdeployqt/CMakeLists.txt
new file mode 100644
index 0000000000..5120b474ae
--- /dev/null
+++ b/tests/auto/tools/macdeployqt/CMakeLists.txt
@@ -0,0 +1,17 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## tst_macdeployqt Test:
+#####################################################################
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_macdeployqt LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_macdeployqt
+ SOURCES
+ tst_macdeployqt.cpp
+)