summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/qdbusxml2cpp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/tools/qdbusxml2cpp/CMakeLists.txt')
-rw-r--r--tests/auto/tools/qdbusxml2cpp/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/tests/auto/tools/qdbusxml2cpp/CMakeLists.txt b/tests/auto/tools/qdbusxml2cpp/CMakeLists.txt
index 4e84d090e7..44bf8166ee 100644
--- a/tests/auto/tools/qdbusxml2cpp/CMakeLists.txt
+++ b/tests/auto/tools/qdbusxml2cpp/CMakeLists.txt
@@ -1,13 +1,19 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# Generated from qdbusxml2cpp.pro.
-
#####################################################################
## tst_qdbusxml2cpp Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qdbusxml2cpp LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qdbusxml2cpp
SOURCES
tst_qdbusxml2cpp.cpp
)
+
+add_dependencies(tst_qdbusxml2cpp ${QT_CMAKE_EXPORT_NAMESPACE}::qdbusxml2cpp)