summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/uic/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/tools/uic/CMakeLists.txt')
-rw-r--r--tests/auto/tools/uic/CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/tests/auto/tools/uic/CMakeLists.txt b/tests/auto/tools/uic/CMakeLists.txt
index 03af78a9c2..2a1d4b5164 100644
--- a/tests/auto/tools/uic/CMakeLists.txt
+++ b/tests/auto/tools/uic/CMakeLists.txt
@@ -1,10 +1,22 @@
-# Generated from uic.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_uic Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_uic LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_uic
SOURCES
tst_uic.cpp
)
+
+# Add dependencies that are implicitly used inside the test
+add_dependencies(tst_uic
+ Qt::uic
+)