summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/windeployqt/testapp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/tools/windeployqt/testapp/CMakeLists.txt')
-rw-r--r--tests/auto/tools/windeployqt/testapp/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/auto/tools/windeployqt/testapp/CMakeLists.txt b/tests/auto/tools/windeployqt/testapp/CMakeLists.txt
new file mode 100644
index 0000000000..ce94cd6464
--- /dev/null
+++ b/tests/auto/tools/windeployqt/testapp/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## testapp Binary:
+#####################################################################
+
+qt_internal_add_executable(windeploy_testapp
+ GUI
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/"
+ SOURCES
+ main.cpp
+ LIBRARIES
+ Qt::Gui
+)
+
+set_target_properties(windeploy_testapp
+ PROPERTIES
+ OUTPUT_NAME testapp
+)