summaryrefslogtreecommitdiffstats
path: root/tests/auto/wasm/fetchapi/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/wasm/fetchapi/CMakeLists.txt')
-rw-r--r--tests/auto/wasm/fetchapi/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/auto/wasm/fetchapi/CMakeLists.txt b/tests/auto/wasm/fetchapi/CMakeLists.txt
new file mode 100644
index 0000000000..335eefc1da
--- /dev/null
+++ b/tests/auto/wasm/fetchapi/CMakeLists.txt
@@ -0,0 +1,22 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## tst_localfileapi Test:
+#####################################################################
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_fetchapi LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_fetchapi
+ SOURCES
+ tst_fetchapi.cpp
+ DEFINES
+ QT_NO_FOREACH
+ LIBRARIES
+ Qt::Core
+ Qt::Network
+)